2011年12月22日 星期四

完全安裝手冊 -- 在 linuxMint12 x64 下安裝 draftsight



1.兩個套件要先安裝起來 libxcb-render-util0(0.3.6-1) 注意要用 0.3.6-1 如果找不到可在這下載 , libdirectfb-extra (1.2.10.0-4ubuntu2)
sudo apt-get install libdirectfb-extra libxcb-render-util0

2.將 draftsight.deb 下載下來放家目錄
3.開啟終端機dpkg-deb -x DraftSight.deb tmp
4.dpkg-deb --control DraftSight.deb tmp/DEBIAN
5.gedit tmp/DEBIAN/control
6.找到 Architecture: i386 改成 Architecture: all 存檔
再重新打包
7.dpkg -b tmp DraftSight_x64.deb

8.點選家目錄下 DraftSight_x64.deb 直接安裝





PS .如果還是不能安裝打開synaptic ,逐檢查下列檔案是不是有安裝


libdirectfb-extra
libxcb-render-util0
libaudio2

sendmail-base (8.14.4-2)
sendmail-bin (8.14.4-2+b1)
sendmail-cf (8.14.4-2)
sendmail (8.14.4-2)
 

sensible-mda (8.14.4-2+b1)

ia32-libs
ia32-libs-gtk
nvidia-glx-ia32 (跟顯示驅動程式有關版本不一定)
libexpat1:i386



如果有缺請先安裝上列檔案再試著安裝 DraftSight_x64.deb  也用下列命令一次檢查
**********************************************************************************************************
* 我發現一個很有趣的問題,如果你先安裝 Teamviewer 大部份缺少的套件都有了。
* 接著再用下面的命令檢查一下,把缺少的再裝起來就可以順利安裝了。                   
* 因為是偶然的發現,所以我下次重安裝時我再把套件差異列出。                               
**********************************************************************************************************

sudo apt-get install libexpat1 libglib2.0-0 libpcre3 libselinux1 zlib1g libc6 libx11-6 libxau6 libxcomposite1 libxcursor1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxi6 libxinerama1 libxrandr2 libxrender1 libatk1.0-0 libcairo2 libdirectfb-extra libfontconfig1 libfreetype6 libgtk2.0-0 libpango1.0-0 libpixman-1-0 libpng12-0 libxcb-render-util0 libxcb-render0 libxcb1 debconf

sudo apt-get install libcomerr2 libdbus-1-3 libexpat1 libgcc1 libgcrypt11 libglib2.0-0 libgpg-error0 libkeyutils1 libpcre3 libuuid1 zlib1g libc6 libgl1-mesa-glx libglu1-mesa libice6 libsm6 libx11-6 libxau6 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxrender1 libxt6 libxxf86vm1 libaudio2 libavahi-client3 libavahi-common3 libcups2 libdrm2 libfontconfig1 libgnutls26 libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0 libstdc++6 libtasn1-3 libxcb1 sendmail




如果還是不行請檢查一下錯誤訊息,試著安裝缺少的函式庫在重新安裝

還有就是「標楷體」這個微軟字型可以用「文泉譯微米黑」
代替顯示就會正常。

2 則留言: